mecamodel logo 1601285362

Sin título 1

 628439184

Pregunta Problema con Switchpilot

Más
7 años 4 meses antes #1 por supertren_es
Problema con Switchpilot Publicado por supertren_es
Buenos días a todos, a ver si los expertos en digital me podéis ayudar pues estoy muy perdido.

El tema es que me han regalado una Z21 y estoy encantado con ella, nunca pensé en digitalizar desvíos ni semáforos ni accesorios, pero con esta central me parece que puede ser muy útil, así que después de mirar mucho, me compré dos Switchpilot y me pongo a hacer pruebas.

Coloco el deco en la vía de pruebas y modifico las CV de las salidas 1, 2, 3 y 4, por lo que veo en el manual se hace modificando las CV 3, 4, 5 y 6. Como quiero conectar 3 motores de desvíos con bobinas de un consumo muy alto “Gauguemaster” y en la 4 quiero poner un semáforo, configuro de esta manera:

CV3 – 1
CV4 – 1
CV5 – 1
CV6 – 64

Hecho esto conecto todo a la vía principal e intento mover bobinas, intento desde la central mover los desvíos con la dirección asignada 1, 2 y 3 y nada. Conecto el semáforo a la 4 y se enciende la luz roja o verde según conecte los cables, pero con la central no muevo nada.

Pienso que es debido a que están mal numerados las salidas e intento numerarlas como dice el manual, pulso el botón del deco y empieza a parpadear el led, y en este punto el manual dice que desde la central se le de un valor a la primera salida y que el resto serán correlativas, pero la gran duda ¿en que sitio de la central doy la dirección? En el apartado de la CV imposible, pruebo de todos modos y nada, no obstante veo las CV 1 y 9 como dice el manual y me indica que están numerados como 1, 2, 3 y 4.

Que puedo hacer? Que estoy haciendo mal?

Gracias a todos de antemano.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #2 por JVC
Respuesta de JVC sobre el tema Problema con Switchpilot
Buenas supertren_es, Primero como as alimentado el decoder con las cuatro salidas de alimentación en digital ,o con corriente analógica y digital ,si solo as alimentado la salida que pone Trk A y Trk B no funcionara el decoder para que te funcione tienes que tener las salidas Pw A y Pw B también conectadas bien a digital o corriente anlógica
Segundo en que posición tienes el decoder en K83 , USER o K84 ,para que te funcione como quieres 3 salidas de impulso y una permanente ,tienes que tenerlo en la posición User
Se me olvidaba para programarlo tienes que tener las 4 salidas de alimentación conectadas
Salidas
El siguiente usuario dijo gracias: supertren_es

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #3 por supertren_es
Respuesta de supertren_es sobre el tema Problema con Switchpilot
Hola, tengo las dos salidas puenteadas y conectadas a la corriente digital, tal y como recomienda el manual. He probado alimentarlas con la vía normal y con la vía de programación. Con esta última cambio y leo las cv sin problema.

El modo seleccionado es user, pero he probado con los otros dos.

Por cierto ya se como asignar la dirección, en el menú de configurar cv hay una opción para leer y modificar la dirección.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #4 por JVC
Respuesta de JVC sobre el tema Problema con Switchpilot
No se a que te refieres que ya sabes como cambiar la dirección que yo sepa solo hay dos maneras una mediante la CV1 y la otra con el botón de programación y un keyboard o teclado
Saludos
El siguiente usuario dijo gracias: supertren_es

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #5 por supertren_es
Respuesta de supertren_es sobre el tema Problema con Switchpilot
Pues con el deco conectado a la via de programacion, le doy al botón del switchpilot durante dos segundos y empieza parpadear el led, en ese momento voy en la central al apartado "cv programin" y en la siguiente pantalla a la derecha abajo hay un sitio que pone loco address. Ahí escribo el número que quiera asignar y debajo hay dos botones " read" y "program" pulso "program" y el led se apaga. Luego si no escribo nada y le doy al botón "read" me dice la dirección que asigné antes.

Da la impresión como que todo funciona hasta el momento que conecto algo ( semaforó o desvío ) ahí me dejo algún paso que hace que no funcione. No se si me dejo algo en la central o en el deco.

Estoy perdido y bloqueado en algún paso.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #6 por supertren_es
Respuesta de supertren_es sobre el tema Problema con Switchpilot
Sigo dándole vueltas al problema, tendrá que ver que tenga locomotoras numeradas con el 1,2,3 y 4???? Son independientes los números de los decos de funciones de los de las locomotoras o hay que dar direcciones que no coincidan?

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #7 por JVC
Respuesta de JVC sobre el tema Problema con Switchpilot
Ya te he entendido lo que parece es que estas programando una locomotora en vez de accesorios ,me imagino que la central tendrá para poder programar accesorios
Saludos

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #8 por JVC
Respuesta de JVC sobre el tema Problema con Switchpilot
Se me olvidaba el decoder solo admite grupos de cuatro es decir CV1 valor 1 se queda programado del 1 al 4 CV1 valor 2 se programa del 5 al 8 y así sucesivamente
Saludos

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes - 7 años 4 meses antes #9 por supertren_es
Respuesta de supertren_es sobre el tema Problema con Switchpilot
Gracias, JVC, esta tarde tocará hacer pruebas a ver lo que pasa. Dado que tu controlas de digital, crees que puede ser por el Railcom?, voy a probar activarlo y desactivarlo en la central, se que en el deco se hace modificando la cv29, me puedes decir cuales son los valores que hay que poner en esta CV para activarlo y desactivarlo?(creo que son 128 desactivado y 136 activado, pero no lo tengo claro) yo me lío un poco con lo del binario.

Gracias.
Última Edición: 7 años 4 meses antes por supertren_es.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #10 por JVC
Respuesta de JVC sobre el tema Problema con Switchpilot
Buenas ,si ves el manual la activación y configuración del RailCom esta en laCV28 y el registro del RailCom esta en el bit 3 de la CV29
Sobre los bit de pende de los decoder ya que algunos van desde 0 al 7 y otros de 1 al 8 ,me imagino que los valores de los bit sabes cuales son, que van desde el 1 del bit 0 ó 1 hasta el bit 7 ó 8 que es 128 los valores que tienen esos bit es el que tienes que introducir en las Cvs que as modificado sus bit
Saludos
El siguiente usuario dijo gracias: supertren_es

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #11 por supertren_es
Respuesta de supertren_es sobre el tema Problema con Switchpilot
Bueno, parece que voy avanzando, efectivamente había dos problemas, el primero de asignación de direcciones, fuí al manual, puse 0 en la cv 1 y 9 y funcionan las salidas como 1, 2, 3 y 4.

El segundo era el Railcom, por algún motivo tuve que desactivarlo para que funcionara, primero lo hice en la central y luego en el deco poniendo 128 en la cv 29 y 0 en la 28.


Asi funcionan las salidas de funciones, lo que no tengo ni idea es como numerar las salidas de los servos, se que es en la cv 35 y 36, sabes como tengo que numerar para darle por ejemplo el valor 5 y 6 a los servos? Que valor tendría que poner en la cv 35-36.

Muchas gracias de antemano JVC.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #12 por JVC
Respuesta de JVC sobre el tema Problema con Switchpilot
Buenas ,en el decoder ya viene de fabrica con ese numero de llamada 5 y 6 ,otra cosa es que quieras modificar la posición inicial y final mas la velocidad de cada salida
de todas las maneras sino recuerdo mal el numero de llamda se modifica en la CV 35 la velocidad en la 37 la posición de inicio en la 38 y el final en la 39 para el servo 1 y para la salida dos serian 40, 41 y 42 ,ya que el numero de llamada lo tomaría automáticamente al programar la salida 5
Saludos

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #13 por supertren_es
Respuesta de supertren_es sobre el tema Problema con Switchpilot
Bueno, al final y después de rompernos la cabeza varias personas en mi casa, hemos dado con la solución.

Lo primero que hay que hacer es desactivar el Railcom, tanto en la central como en la cv 29, no se el motivo, pero si no se hace el deco no funciona. De fábrica viene con el activado.

Para el tema de los servos, hay que modificar la Cv 50, darle valor 2, por lo que hemos deducido, si no lo haces, el servo no recuerda la posición en la que debe estar y la esta localizando contínuamente.

Espero que esto sirva para el próximo que compre este modelo de deco.

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
7 años 4 meses antes #14 por JVC
Respuesta de JVC sobre el tema Problema con Switchpilot
Buenas supertren _es
Vamos por parte cuando se pregunta por una cosa hay que facilitar la mayor información posible ,en este caso tu as preguntado por un decoder no especificando el modelo por lo que as comentado es el V.2 el cual es tiene barias modificaciones con el V1
Una de ellas es proporcionar el final del recorrido el cual se fija con el bit 1 de la CV50
Otra y principal es que el decoder solo tendrá corriente cuando pulsa su numero de llamada ,con eso se evita que al conectar la central tenga un movimiento de impulso
para evitar eso hay que configurar el bit 2 de la CV50
Saludos

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Esta web utiliza 'cookies' propias y de terceros para ofrecerte una mejor experiencia y servicio. Al navegar o utilizar nuestros servicios, aceptas el uso que hacemos de ellas. Puedes cambiar la configuración de 'cookies' en cualquier momento. Más información